Trisquel NOTIFICATION problem

30 replies [Last post]
iShareFreedom
Offline
Joined: 12/20/2021

Trisquel by default dont have notification sound program, that mean programs like gajim, hexchat and others can be affected and dont work properly in Trisquel (MATE)

prospero
Offline
Joined: 05/20/2022

I believe you should be able to set the volume for audio notifications through Control Center > Sound > Sound Effects tab. Make sure that "Alert volume" is not muted and that "Enable window and button sounds" is checked. Also, make sure a theme is selected.

This works for me on Trisquel 10.0.1 Nabia, although I usually keep sound effects muted. Not sure what the default settings are.

Avron
Offline
Joined: 08/18/2020

I have a problem here actually. I have the Trisquel theme selected, the alert volume is set to zero.

If I raise it, still no notification sound (but the notification window works fine). If I close the window and open it again, the volume for audio notifications is still set to zero.

This is on aramo on my desktop.

iShareFreedom
Offline
Joined: 12/20/2021

That problem looks more a problem of the aler volume then the notification windows. You try it, with other kernel? For example the gnu-linux-libre? I have similar problem with Trisquel 10, but i change to libre 5.10.147-gnu1 and work very good.

prospero
Offline
Joined: 05/20/2022

> You try it, with other kernel? For example the gnu-linux-libre?

Gnu/Linux-libre is not a kernel, it is an operating system.

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

GNU Linux-libre (with a space) is a kernel though: https://www.gnu.org/software/linux-libre/

prospero
Offline
Joined: 05/20/2022

True. Note that the space is critically important: if one misses it, one might slip into confusion.

iShareFreedom
Offline
Joined: 12/20/2021

I say gnu-linux-libre, trying to say Linux-libre part of the GNU Project. https://www.gnu.org/software/linux-libre/ instead isnt Gnu the name of the OS, the name is GNU, and Linux-libre is one of their kernels.

prospero
Offline
Joined: 05/20/2022

> I say gnu-linux-libre, trying to say Linux-libre

Weird. But no matter, this is not the point anyway. Using a different kernel version for a minor glitch in the sound settings GUI in a beta iso is unheard of in these lands. Glad that it worked for you.

prospero
Offline
Joined: 05/20/2022

> This is on aramo

Then I would update my system and report this on the aramo thread: https://trisquel.info/en/forum/new-aramo-beta-iso-amd64. Aramo is progressing at light speed, but is still work in progress.

prospero
Offline
Joined: 05/20/2022

On a live session everything works as expected, except that the altert volume can only be set either on or off, which in effect makes the alert volume bar irrelevant: one only needs to check or uncheck the "mute" button. The alert volume level is determined by the general output volume level. However, moving the alert volume bar cursor down to zero also has the effect of checking the "mute" button. Unchecking it turns the alert volume back on.

EDIT: This is how my Sound Preferences look like with sound effects turned on and audible:

Alert_volume.png
Avron
Offline
Joined: 08/18/2020

Thanks for testing and reporting.

I have the same settings, I hear the sound effects, e.g. when clicking on the menu button in the mate panel, but notifications from all installed programs (evolution, gajim, jami) are silent.

I suppose you probably did not have anything that triggers alerts when on a live system.

Note sure whether it is important: I use mate but with fvwm instead of marco. I created a fvwm.desktop file in ~/.config/autostart so that it is started with the mate session. I tried "gsettings set org.mate.session.required-components windowmanager fvwm" but then, no window manager is started (I still have that setting). It would be good to try the "regular" mate+marco but I would need to find a method to select mate+marco or mate+fvwm at session start, or even to switch between the two options. After more than one year of using mate+marco as a daily driver, I still fell extremly frustrated and that frustration entirely goes away with fvwm.

prospero
Offline
Joined: 05/20/2022

I can confirm that I am not getting any sound alert when notification popups appear.

I can remember at least two threads where we discussed notifications, and specifically libnotify, and how to test it. We may be able to extract useful information from these threads if ever we manage to retrieve them, assuming that these notification events are actually supposed to play a sound.

EDIT: those threads in fact refer to the same script, where libnotify is tasked with sending some text (which then appears in the popup notification) while 'aplay' plays a sound. I am still unsure whether a sound is supposed to be played by default when these notifications are displayed.

Avron
Offline
Joined: 08/18/2020

I am still unsure whether a sound is supposed to be played by default when these notifications are displayed.

I did configure the sound to be played by evolution upon email arrival and have the "show notification" option on. I saw the notifications but did not hear any sound (like for gajim and jami).

I just tried changing the notification sound in evolution, opened claws-mail, loaded the notification module and ... suddenly I have notification sounds for evolution and for gajim.

Which of my actions triggered this change? No clue.

EDIT: Sounds is one case where I am not convinced of the benefit of having a general control over several programmes, besides a general volume control.

EDIT2: It stopped working again. The only thing that might be related that I did was to remove the system sounds (that I have no interest in) and close the settings window. Will continue fooling around with that.

prospero
Offline
Joined: 05/20/2022

You are going too fast for me, but yes, there should definitely be an audio signal pottering along with these notifications. There are a few commits that fixed sound related problems in the mate-notification-daemon github.

A 2015 commit seems to have taken the "default-sound" key out of mate-notification-daemon because it was "not really used anywhere". Maybe using it somewhere instead of deleting it would have been a better idea? Difficult to tell without diving into the source, but I believe I would try to report these problems there if tinkering around cannot solve them satisfactorily and if they persist after Aramo is out: https://github.com/mate-desktop/mate-notification-daemon.

Avron
Offline
Joined: 08/18/2020

Here is what I think are observed:

- initially, notifications are silent

- if I play any sound, e.g. "mpv /usr/share/sounds/freedesktop/stereo/bell.oga", the sound is played and after that, there is a sound for every notification

- at some point later (not sure when, but I recently have a new thing since a few days: my desktop goes to sleep every night, while there is nothing in the power management option telling it to do that, don't know whether it is that which makes notifications silent again), notifications are silent again

right after, there is a sound with each notification

prospero
Offline
Joined: 05/20/2022

EDIT: Long story short: commenting out the "load-module module-suspend-on-idle" line in /etc/pulse/default.pa provides a simple workaround if the problem is caused by the sound card being slow to get out of suspend mode.

Avron
Offline
Joined: 08/18/2020

I commented that line out and rebooted but the same still occurs:

When I play /usr/share/sounds/freedesktop/stereo/message-new-instant.oga (just with the mpv command in a terminal) while no sound was played for a while, I hear something so muffled that I may won't notice it if I am not carefully listening.

If I run the same command again, the sound is played normally.

prospero
Offline
Joined: 05/20/2022

> If I run the same command again, the sound is played normally.

What if you wait say 10 sec before running the command again? On my system, commenting that line out solved the muffled sound problem you are describing here - although not the original notification sound problem. With the suspend-on-idle module loaded, I can clearly hear the sound being turned on, but too late to play the alarm sound in time, and if I wait about 5-6 seconds without any audio playing I can also hear the sound card being turned off again.

Avron
Offline
Joined: 08/18/2020

> What if you wait say 10 sec before running the command again?

I tried up to 300s (sleep command), the second sound is still played normally.

prospero
Offline
Joined: 05/20/2022

There may be some other option that holds your sound output back when first used (e.g. loading codec or whatnot).

When you say "up to 300s", is that with the line commented out? If I comment it out on my system, clearly the muffled sound problem is solved. If I don't, the first alarm played after the sound card has been suspended (about 6 seconds after last sound file ended) is hardly audible. Maybe your sound card does not advertise its idle states? Anyway, we are now probably tracking a different problem to the missing notification sound.

Avron
Offline
Joined: 08/18/2020

>When you say "up to 300s", is that with the line commented out?

Yes.

>Maybe your sound card does not advertise its idle states?

According to lsusb, it is:
Bus 004 Device 002: ID 0d8c:0014 C-Media Electronics, Inc. Audio Adapter (Unitek Y-247A)

Not sure how to check that.

EDIT: the behaviour is exactly the same on my X200 with Trisquel 10.

EDIT 2: actually, no, it is different:
- on the X200, I still hear the sound, a bit muffled. Also, it has the 10s timeout that you mentioned (so I will try your mitigation)
- on the desktop, what I hear is not the sound, it is a kind of very light pop and very brief white noise, and there is no 10s timeout.

prospero
Offline
Joined: 05/20/2022

Sorry I was busy installing Trisquel 11 after failing to properly upgrade from Trisquel 9. In short, I did hit the "not enough space available on the system partition" problem and mishandled the situation to the point that I smashed my /home partition thinking I was erasing some old junk (well...). Then I got a few efi-related hickups and eventually managed to re-emerge thanks to an old but life-saving post of chaosmonk's.

I can confirm the situation on this freshly installed Trisquel 11 is still exactly the same as described above, same sound card.

iShareFreedom
Offline
Joined: 12/20/2021

Yes, the problem is solved anyway i dont know how, but now works perfectly thanks prospero, anyway you know how to modify the notifications? the theme of the notifications in trisquel? with Notification Config of MATE i cant change nothing, looks bug

prospero
Offline
Joined: 05/20/2022

If the picture below is what you are talking about, then I am experiencing the same situation: changes made in either dconf or the Notifications GUI have no effect.

https://screenshots.debian.net/package/mate-notification-daemon#gallery

No idea what the back-end is supposed to be, never needed to change the default settings.

iShareFreedom
Offline
Joined: 12/20/2021

Yes, im speaking about the mate-notification-daemon

prospero
Offline
Joined: 05/20/2022

I would think most users just never noticed that bug, because the default behavior works fine.

You may get more info looking at your logs, clearly the GUI input is not properly getting sent to the backend, for whatever reason. I could not find any config files, only theme files, so either the default theme is hard coded, or I did not look at the right place.

EDIT: This commit possibly fixed the problem in MATE 1.26, and thus hopefully for Trisquel 11:
https://github.com/mate-desktop/mate-notification-daemon/pull/196/commits/7d081a0fceea882ad01fe34f9efc54584d6a1183

iShareFreedom
Offline
Joined: 12/20/2021

I dont know how apply that commit in my Trisquel GNU

prospero
Offline
Joined: 05/20/2022

You need to recompile mate-notification-daemon with the modified source file, or wait until you can upgrade to Trisquel 11 and it will most probably have been done for you.

If you would like that fix to be available in Trisquel 10 Nabia, you need to report the bug, or even better to discuss it first on the #trisquel libera.chat IRC channel. This is an upstream bug, so you may report to MATE instead and ask there if the 1.26 fix can be backported to 1.24:

https://github.com/mate-desktop/mate-notification-daemon/issues

prospero
Offline
Joined: 05/20/2022

[wrong indent]

iShareFreedom
Offline
Joined: 12/20/2021

I fix the notification popup problem of trisquel removing the package called notify-osd

so, sudo apt remove notify-osd or in synaptic.